I have an existing Cisco switch, and I've configured one of its ports as a Trunk port, with VLAN tagging using 802.1Q. I wanted to get that working with my Mikrotik RB4011iGS+RM, using ether1 as the trunk port, and ether2-ether10 each being access ports for various VLANs. However after following the tutorials in the docs it did not work as I expected. I did eventually get it working, but not after the failed attempt below, which was based off of the following two tutorials:
However with this configuration, I stopped receiving any traffic once I enabled vlan-filtering=yes on the bridge.
After some digging around, I found this post: viewtopic.php?p=1017584#p1017577, which says:
I'm confused why the tutorials I was looking at didn't even mention adding bridge1 as a tagged interface under the VLAN bridge. Am I misunderstanding what the tutorial was trying to do? Or maybe the tutorial made some assumptions about pre-existing configuration?
My config is functioning as I would like for now, so I don't need immediate help. But I'm just wondering what I maybe missed, or alternative just confirmation that the tutorials missed something.
- * https://help.mikrotik.com/docs/display/ ... sportsetup
* https://help.mikrotik.com/docs/display/ ... ccessPorts
Code:
## Add bridge1/interface bridge add name=bridge1 vlan-filtering=yes## Add trunk port to bridge1/interface bridge port add bridge=bridge1 interface=ether1 frame-types=admit-only-vlan-tagged## Add access ports to bridge1/interface bridge port add bridge=bridge1 interface=ether2 pvid=10 frame-types=admit-only-untagged-and-priority-tagged/interface bridge port add bridge=bridge1 interface=ether3 pvid=10 frame-types=admit-only-untagged-and-priority-tagged/interface bridge port add bridge=bridge1 interface=ether4 pvid=10 frame-types=admit-only-untagged-and-priority-tagged/interface bridge port add bridge=bridge1 interface=ether5 pvid=10 frame-types=admit-only-untagged-and-priority-tagged/interface bridge port add bridge=bridge1 interface=ether6 pvid=30 frame-types=admit-only-untagged-and-priority-tagged/interface bridge port add bridge=bridge1 interface=ether7 pvid=30 frame-types=admit-only-untagged-and-priority-tagged/interface bridge port add bridge=bridge1 interface=ether8 pvid=20 frame-types=admit-only-untagged-and-priority-tagged/interface bridge port add bridge=bridge1 interface=ether9 pvid=99 frame-types=admit-only-untagged-and-priority-tagged/interface bridge port add bridge=bridge1 interface=ether10 pvid=99 frame-types=admit-only-untagged-and-priority-tagged## Add vlans, and tag them on ether1 (trunk)/interface bridge vlan add bridge=bridge1 tagged=ether1 vlan-ids=10/interface bridge vlan add bridge=bridge1 tagged=ether1 vlan-ids=20/interface bridge vlan add bridge=bridge1 tagged=ether1 vlan-ids=30/interface bridge vlan add bridge=bridge1 tagged=ether1 vlan-ids=99
After some digging around, I found this post: viewtopic.php?p=1017584#p1017577, which says:
This makes sense after reading more in the documentation. So I changed the last section of my config to the following, which worked great:You need to add the name of the bridge itself as a tagged port.
This represents the "CPU side" of the bridge.
Code:
## Add vlans, and tag them on ether1 (trunk)/interface bridge vlan add bridge=bridge1 tagged=ether1,bridge1 vlan-ids=10/interface bridge vlan add bridge=bridge1 tagged=ether1,bridge1 vlan-ids=20/interface bridge vlan add bridge=bridge1 tagged=ether1,bridge1 vlan-ids=30/interface bridge vlan add bridge=bridge1 tagged=ether1,bridge1 vlan-ids=99# Added bridge1 here ^^^^^^^
My config is functioning as I would like for now, so I don't need immediate help. But I'm just wondering what I maybe missed, or alternative just confirmation that the tutorials missed something.
Statistics: Posted by C28AB — Sat Jan 13, 2024 8:12 pm