perhaps
/interface/bridge/port disable [find where interface=ether9]
/interface vlan add name=voip_vodafone_vlan vlan-id=838 interface=ether9
/interface pppoe-client add name=pppoe_connection_for_vodafone_voip user=guest@onenetvoice.gr password=guest \
interface=voip_vodafone_vlan disabled=no
/interface list member add interface=ether9 list=WAN
/interface list member add interface=voip_vodafone_vlan list=WAN
/interface list member add interface=pppoe_connection_for_vodafone_voip list=WAN
; The following default masquerade rule should already exist
;/ip firewall nat add action=masquerade chain=srcnat out-interface-list=WAN
; Also this rule should already be present in filter
; add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new \
in-interface-list=WAN
With luck this will get the voip connection up and running to the ISP but you still have to get the connection to the phones.
/interface/bridge/port disable [find where interface=ether9]
/interface vlan add name=voip_vodafone_vlan vlan-id=838 interface=ether9
/interface pppoe-client add name=pppoe_connection_for_vodafone_voip user=guest@onenetvoice.gr password=guest \
interface=voip_vodafone_vlan disabled=no
/interface list member add interface=ether9 list=WAN
/interface list member add interface=voip_vodafone_vlan list=WAN
/interface list member add interface=pppoe_connection_for_vodafone_voip list=WAN
; The following default masquerade rule should already exist
;/ip firewall nat add action=masquerade chain=srcnat out-interface-list=WAN
; Also this rule should already be present in filter
; add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new \
in-interface-list=WAN
With luck this will get the voip connection up and running to the ISP but you still have to get the connection to the phones.
Statistics: Posted by rplant — Sat Feb 03, 2024 2:08 am